Massive Console Spam Freezing Server



  • So far, this has only happened on a single map that I ported recently.

    All of a sudden, the server’s console will flood with a massive amount of commands (or errors) being entered.  The server will then freeze up and players get irritated.

    This does not happen on any other map and this seems to have begun after I compiled the new version.

    In this new version:
    Fast zombies and headcrabs are not allowed (used -1 for waves)
    I added two more point_worldhint (one that gets hidden after opening a door)
    I added three more kinds of boxes (four versions, each have different max HP)
    I added a dispenser that spawns a healthvial every 2 minutes on a button push with a sound that plays

    It is a very basic map and a server favorite. For those of you who played ZM, it is a port of zm_boxfort_b2 (now called zs_boxfort_b4). There are no errors shown in hammer.

    It only seems to happen when the server votes to play that map (it is the server default and normally does not experience any issues as the default map).

    See attached images

    I am unsure of what each of these mean, but the majority of them seem to all begin with  TEST. They all show up in the console at, what seems to be, the fastest rate possible for a computer.

    I would go into the files myself and attempt to fix it, but the location does not seem to be that of which I can find. >.<

    Assistance is greatly appreciated.

    EDIT: This is from the Workshop version. I will try to use the most up-to-date version and edit this post with results.



  • So far, this has only happened on a single map that I ported recently.

    All of a sudden, the server’s console will flood with a massive amount of commands (or errors) being entered.  The server will then freeze up and players get irritated.

    This does not happen on any other map and this seems to have begun after I compiled the new version.

    In this new version:
    Fast zombies and headcrabs are not allowed (used -1 for waves)
    I added two more point_worldhint (one that gets hidden after opening a door)
    I added three more kinds of boxes (four versions, each have different max HP)
    I added a dispenser that spawns a healthvial every 2 minutes on a button push with a sound that plays

    It is a very basic map and a server favorite. For those of you who played ZM, it is a port of zm_boxfort_b2 (now called zs_boxfort_b4). There are no errors shown in hammer.

    It only seems to happen when the server votes to play that map (it is the server default and normally does not experience any issues as the default map).

    See attached images

    I am unsure of what each of these mean, but the majority of them seem to all begin with  TEST. They all show up in the console at, what seems to be, the fastest rate possible for a computer.

    I would go into the files myself and attempt to fix it, but the location does not seem to be that of which I can find. >.<

    Assistance is greatly appreciated.

    EDIT: This is from the Workshop version. I will try to use the most up-to-date version and edit this post with results.



  • Well, after switching to the most recent version on githud, it began to look good.

    However, it just happened again after the map was voted to zs_boxfort.

    Any support would be appreciated.


  • Administrators

    It could be someone exploiting the fact that clients can send their errors to the server console (why this was a good idea, who knows) and someone is just doing it as fast as possible.

    printing TEST messages isn’t part of the gamemode.



  • I suppose that is plausible, but, generally, there are different players on the server (server is relatively new, still drawing people in). This has happened with the server pretty filled up (18+ people) as well with a small amount (6-8). I do not think there would be many people who would know about such an exploit, let alone kill a new server they were playing on for a while.
    If it makes a difference, the only addons I had installed (when this began) was ULX and pointshop.


  • Administrators

    Do you have the server subscribed to the workshop addon? Try just putting the raw files from the github in a gamemode folder. If I remember correctly, the TEST messages only happen for addons.



  • @JetBoom:

    Do you have the server subscribed to the workshop addon? Try just putting the raw files from the github in a gamemode folder. If I remember correctly, the TEST messages only happen for addons.

    Actually, I do. I forgot to unsubscribe the server from it…

    I will make another post soon on the results.



  • So far, so good! Map voted to zs_boxfort_b4 with 18 players and the TEST errors never showed up!

    Thank you, Jetboom.


Log in to reply
 

6
Online

10976
Users

15257
Topics

297327
Posts

Looks like your connection to NoXiousNet was lost, please wait while we try to reconnect.