Broken stuff thread



  • Post here bugs you found since the update. Be descriptive and if possible a way to replicate it.

    I am already aware of a bunch of costumes being broken with the wrong scales.



  • Post here bugs you found since the update. Be descriptive and if possible a way to replicate it.

    I am already aware of a bunch of costumes being broken with the wrong scales.



  • Killing fast legs makes whole fast zombie appear dead.





  • Models are set to the textureless default in theater.  If you are hit with corrupted blade the darkness persists after death.  When switching classes in rtp from one that has a weapon on spawn to another, that weapon can remain in the hand of the new model.  When nailed props are broken they remain frozen in place until they’re destroyed.

    This:

    TEST [gamemodes/zombiesurvival/entities/entities/zombiegasses/cl_init.lua][gamemodes/zombiesurvival/entities/entities/zombiegasses/cl_init.lua]
    FOUND IN ADDON [0]
    TEST [gamemodes/zombiesurvival/entities/entities/zombiegasses/init.lua][gamemodes/zombiesurvival/entities/entities/zombiegasses/cl_init.lua]
    TEST [gamemodes/zombiesurvival/entities/entities/zombiegasses/shared.lua][gamemodes/zombiesurvival/entities/entities/zombiegasses/cl_init.lua]

    [ERROR] gamemodes/zombiesurvival/entities/entities/zombiegasses/cl_init.lua:44: Tried to use invalid object (type CLuaEmitter) (Object was NULL or not of the right type)
      1. Add - [C]:-1
      2. unknown - gamemodes/zombiesurvival/entities/entities/zombiegasses/cl_init.lua:44

    Using haste in rtp results in these errors for everyone on the server.

    http://puu.sh/7WATN.png

    Some kind of particle effect on the stun stick in theater is missing.  There is an error client-side when it is equipped.

    This error happens constantly in theater.

    [ERROR] gamemodes/cinema/entities/entities/prop_teleport/cl_init.lua:48: Tried to use invalid object (type CLuaEmitter) (Object was NULL or not of the right type)
      1. Add - [C]:-1
      2. unknown - gamemodes/cinema/entities/entities/prop_teleport/cl_init.lua:48



  • Is that error spammed or is it only one time? See if the particles aren’t coming out of the telepad anymore.



  • It’s spammed constantly.  There are no particles, but the pulsing rings are still there.



  • Also in Cinema, the chess boards are also broken.
    You can sit in the chairs, but the UI for the boards is missing/gone
    but the pieces are there.



  • Players get these errors on zombie survival.

    [ERROR] gamemodes/zombiesurvival/entities/entities/zombiegasses/cl_init.lua:12: Tried to use invalid object (type CLuaEmitter) (Object was NULL or not of the right type)
      1\. Finish - [C]:-1
       2\. unknown - gamemodes/zombiesurvival/entities/entities/zombiegasses/cl_init.lua:12
    
    [ERROR] gamemodes/zombiesurvival/entities/entities/prop_gunturret/cl_init.lua:39: Tried to use invalid object (type CLuaEmitter) (Object was NULL or not of the right type)
      1\. Finish - [C]:-1
       2\. unknown - gamemodes/zombiesurvival/entities/entities/prop_gunturret/cl_init.lua:39
    

    Ironsight weapon positioning became slower on the server, because of the change

    • Changed GM:CalcViewModelView, return a position and an angle to override viewmodel position

    • vm_origin and vm_angles fields in table returned from GM:CalcView are now deprecated

    @_killburn:

    Viewmodel repositioning used to be done in CalcView, now it is done in CalcViewModelView because it is a much more appropriate place (it also fixes viewmodels becoming jittery after a while).

    Now that CLuaEmitter:Finish is fixed, could the poison/puke decals on walls make a return?

    The +use action is duplicated on prop drop, allowing the player to auto-drop+pick another prop in one instance of +use, or drop a prop and use the deployable/switch

    Publish 409: Fixed players being able to press USE on things while they were holding something.



  • TP2: Screen overlay for corrupted blade never goes away
    The texture effect for flesh wound doesn’t go away. (While you’re at it, it should be team colored. It’s red no matter what team you’re on)
    Ditto for salamander skin.



  • @Box:

    Now that CLuaEmitter:Finish is fixed, could the poison/puke decals on walls make a return?

    They aren’t particles.



  • At this point all the bugs in the thread should be fixed. Except for the ironsights being delayed when you right click.



  • Gibs from gibbable css props don’t disappear.



  • Didn’t they always do that?



  • I think so.



  • The z9000 pulse pistol is really tiny, reload and firing sounds do not play.



  • Twitch Streams no longer work in MPTV



  • I died while bleeding with hemophilia and the bleed bar stayed after death, stuck at 2.

    Edit: It even stayed on round restart.

    Edit2: It disappeared after round 1 started.



  • tiny slug



  • Clicking “empty clip” with a “savior” medic gun does nothing.
    You also can’t do it with the medkit.


Log in to reply
 

7
Online

11.3k
Users

15.5k
Topics

300.1k
Posts

Looks like your connection to NoXiousNet was lost, please wait while we try to reconnect.