Unplayable fps



  • On nearly every map, and especially later in the rounds, my fps is always super laggy single digit bullshit. I’ve been doing experimenting and trying to see if i can tweak the settings or anything to get any improvements. Nothing has really shown any significant changes in fps, only making the game look worse with the same framerate. If i play a zs map in singleplayer i get 5-10x as much fps than when on noxious zs server, i understand there is alot more to render but still. Poorly optimized maps in TTT get 50+ fps. Is this is all due to multicore rendering? I hear people getting 50-60 fps, if so what specs are your computer? As im most likely going to be in the market for a new computer.

    playing on noxious:

    singleplayer:



  • On nearly every map, and especially later in the rounds, my fps is always super laggy single digit bullshit. I’ve been doing experimenting and trying to see if i can tweak the settings or anything to get any improvements. Nothing has really shown any significant changes in fps, only making the game look worse with the same framerate. If i play a zs map in singleplayer i get 5-10x as much fps than when on noxious zs server, i understand there is alot more to render but still. Poorly optimized maps in TTT get 50+ fps. Is this is all due to multicore rendering? I hear people getting 50-60 fps, if so what specs are your computer? As im most likely going to be in the market for a new computer.

    playing on noxious:

    singleplayer:



  • Try disabling cosmetics in the NoXNet options menu.



  • @Zetanor:

    Try disabling cosmetics in the NoXNet options menu.

    I’ve tried, not really much noticeable difference, just 1-2 fps.



  • Rendering the map is going to be a lot less than rendering the map and a bunch of players/effects/etc.



  • @JetBoom:

    Rendering the map is going to be a lot less than rendering the map and a bunch of players/effects/etc.

    Which leads me to another question, is there a way to turn off gore? It is brutal on my fps, especially with like 20+ zombies exploding everywhere.

    Hell maybe its time to go all out and buy a new computer. I dunno.



  • Remove the blood effects when you headshot a zombie. It’s blocky and completely blocks your vision and even the front of the cade for a second if there are enough zombies. Also disable rendering of water splashes. It’s so laggy that it freezes up the game for a few seconds.



  • @Humin:

    Remove the blood effects when you headshot a zombie. It’s blocky and completely blocks your vision and even the front of the cade for a second if there are enough zombies. Also disable rendering of water splashes. It’s so laggy that it freezes up the game for a few seconds.

    I couldn’t agree more. Maps like alive metal, where you cade pretty much in water. It can lag like crazy with shitloads of people splashing around.



  • More cvars and a tab in the F4 menu dedicated to performance options, would be good for everyone.



  • I don’t have any issues with splashing or blood effects? It’s also pertinent to know that water splashing isn’t anything I’ve made. That’s in the engine and if it’s lagging you then you probably have something deeper to worry about like not running on a toaster.



  • What are your PC specs dank?



  • I’m playing on a laptop i bought about a year and a half ago, it’s a pavilion M6 running windows 7. AMD A10-4600M APU 2.3 GHz with , 6 GB of ram, and AMD Radeon HD 7660g.



  • I used to have a 2.4 GHz CPU, or somewhere around there. Game played like shit, same fps with full high visual effects as with bare essentials. I feel like the game just takes a lot of processing power and it only uses a single core. My parents’ PC with a shit graphics card and maybe a 3.0 GHz duel core played it quite a bit better but only when graphics settings were low. Before I got a graphics card for my current PC the game had roughly the same fps as with it.



  • After some advice from Sun, and some experimentation in game, we have found somewhat of a fix.
    1.run box(windows key + r)
    2.type msconfig into the box
    3. then select boot
    4.selecting advanced options
    5. From there you change your number of processors to 2
    6.restart your computer
    I’m waiting to test fire forest in game on nox, but single player showed some very significant improvements, about double the fps from before.

    SINGLEPLAYER 2 cores

    SINGLEPLAYER 4 cores

    Ohoh yeah



  • Well that’s silly, you should just start hl2.exe with only 2 cores.



  • Wait a sec-

    isn’t there an option in the menu to disable multi-core something?



  • This forces the turbo boost to be always available by disabling two of the cores, since the maximum boosted state of 3.2ghz only triggers when at least two of the cores are sitting at the lowest power state. The windows OS likes to cycle new threads on the least utilized core, so that condition is hardly ever achieved on its own. The background processes are almost always enough to trigger lowered turbo boost, causing uneven fps as it fluctuates from high to low boost.
    Combine this with something like K10stat, pscheck, or RMclock to lock at a higher frequency. If anyone knows how to lock individual core’s frequency independent of each other, please let me know.

    Gmod being cpu intensive, and showing very little gain from multiple cores, runs faster with a 3.2ghz dual core rather than a 2.3ghz quad core.

    This should work on most modern cpus that come with the turbo boost feature, since they all work similarly as described above.

    The obvious disadvantage is that you are losing two cores, and the default vcore for the boosted state is considerably high, causing increased temperature. May even throttle from thermal limit causing slower overall performance. Combine with undervolting if necessary.

    Some cpus have architecture specifics ways to achieve similar effect, google yours before trying this. I’d be glad to help a toaster owner wanting to play.

    If you know of any other gmod specific tweaks for performance, please do share.

    Thanks for the optimization in publish 407, helped quite a bit.

    @JetBoom:

    I don’t have any issues with splashing or blood effects?

    cl_show_splashes 0 for water splash off. Multiple people shooting into water, likely to happen in ze, is less laggy.
    Big stacks of blood decals concentrated in one spot causes massive lag for me. Happens quite easily with 30+ zombies piling in front of the barricade.
    mp_decals <number> to limit number of decals. Alternatively r_cleardecals once in the console whenever you start to feel the stutter. Bind it for easy access. Tested today, nets about 5 fps when used middle of the round.
    r_shadows 0 if you are playing on an ipad. The dynamic lights from manhacks seem to add up on performance cost.



  • @ChiRaeDisk:

    Wait a sec-

    isn’t there an option in the menu to disable multi-core something?

    garry disabled multi-core rendering due to the many crashes it caused during gm13 beta.
    As of now, the option is present but it doesn’t enable multi-core rendering.


Log in to reply
 

3
Online

11023
Users

15276
Topics

297664
Posts

Looks like your connection to NoXiousNet was lost, please wait while we try to reconnect.