Help! Zombies Crashes! [RESOLVED]



  • –Hear me out!–
    I have looked around for others having this problem, and YES there are people, but my issue is slightly different.
    I play zombies all the time, and I have started encountering a severe issue during match play. After about 10-15 minutes in a map, Gmod hits a severe lag spike and crashes completely. In the reports I’ve read, this crash is usually followed by a crash reporter. In my case, however, nothing happens. Gmod simply closes and leaves me back in my Steam library. When I looked in the Gmod files however, the crash reports are there. The crashes are extremely frustrating, especially at the 5th or 6th wave when logging in again causes me to appear as a zombie, not a healthy, happy human. I would like to see this issue fixed, but I have no idea how.
    Any help?

    Computer specs:
    OS: Windows 7 HP
    Processor: Intel i7 2.67~2.7 GHz (hyperthreaded to 8 cores)
    Memory: 8192 MB RAM
    Card: NVIDIA GeForce GTX 550 Ti
    (Probably irrelevant) DirectX Version: DirectX 11



  • –Hear me out!–
    I have looked around for others having this problem, and YES there are people, but my issue is slightly different.
    I play zombies all the time, and I have started encountering a severe issue during match play. After about 10-15 minutes in a map, Gmod hits a severe lag spike and crashes completely. In the reports I’ve read, this crash is usually followed by a crash reporter. In my case, however, nothing happens. Gmod simply closes and leaves me back in my Steam library. When I looked in the Gmod files however, the crash reports are there. The crashes are extremely frustrating, especially at the 5th or 6th wave when logging in again causes me to appear as a zombie, not a healthy, happy human. I would like to see this issue fixed, but I have no idea how.
    Any help?

    Computer specs:
    OS: Windows 7 HP
    Processor: Intel i7 2.67~2.7 GHz (hyperthreaded to 8 cores)
    Memory: 8192 MB RAM
    Card: NVIDIA GeForce GTX 550 Ti
    (Probably irrelevant) DirectX Version: DirectX 11



  • r_drawmodeldecals 0, place that into autoexec.cfg in garrysmod/cfg
    or as a start up command +r_drawmodeldecals 0

    See if that works for you.



  • Worked like a charm. Thanks!


  • Administrators

    Can you give me your crash dumps from when it was happening? I’ll try to get garry to look at them. People shouldn’t have to put stuff in the command line to be able to play.

    If anyone else is still crashing a lot but this didn’t fix it then you can give me those too.



  • I’ll take out the command line stuff for now, and try to see if it happens again. In my quest to fix it myself before I went to the forums, I deleted all the old crash logs. Sorry.



  • I have the same problem, but i don’t know where r_drawmodeldecals 0 is or what to do with it.  ???



  • Right click gmod in steam library > properties > set launch options > add “+r_drawmodeldecals 0” in the text box (no quote)

    Simply delete it from the text box whenever the problem is said to be fixed.



  • I have my crash dumps if you want those, let me know.


  • Administrators

    If you crashed while in ZS then yeah.



  • Yes I did, I have like 7 crash reports.



  • I’ve been trying to get to the bottom of this for a while, and with help from Codebrain, I was able to conclude the main culprit for the crash is the poison decals left on the player models from zombie’s poison throwing attacks. (Blood decals seem to cause a similar crash.)

    When poison hits a player, they leave poison textures on the player where they were hit.


    However, since update 164 with its LOD optimization on the playermodels, splashed poison becomes distorted at random.
    After a while, these would stack up, and I noticed decreased fps and higher frame time variance.

    There seems to be multiple point where it actually crashes, but I was able to reliably replicate a crash if I noclipped far away from a large cluster of these distorted decals, then come back near them.

    I played a demo : http://www.mediafire.com/download/5yfvffla77zyi2b/r_drawmodeldecals+crash.rar
    with the map : http://heavy.noxiousnet.com/downloadurl/maps/cs_besenyei.bsp.bz2
    15 times with +r_drawmodeldecals 0 and did not crash.
    and played 25 times with +r_drawmodeldecals 1 and crashed 10 times using noclipping in and out method.
    Distorted decals happen at random, and it seems to need quite a few decals stacked to cause a crash.

    Tested with multiple hardware configurations and settings. Intel, AMD, Nvidia all crashed more than once. Tested on both dx8.1 and 9

    +r_drawmodeldecals 0 stops the poison decals from being rendered on the models, and is a good temporary fix for the crash.
    However, I see many players still repeatedly suffer from the crashing, and I suspect even more never bothers coming back.

    I understand that there is little you can do to fix Garry’s an moran coding, but thanks for looking into the problem.
    I will email you the crash dumps.



  • This might sound a bit weird, but it seems to be that when you get far enough away from a human for their lod to swap, the decals themselves “forget” that the lod was changed get confused as to what faces/vertices to be attached to. As a result, its probably something having to do with the decal trying to attach to faces/vertices that don’t exist and as a result corrupting some memory, resulting in the crash.


  • Administrators

    If it’s blood decals getting distorted does that mean that any blood decals (bullets) do it or just the ones created by the gamemode? Either way, garry knows about it now so if he can find it, he’ll fix it next version I guess.



  • Would it be possible to temporarily disable all model decals on the server?



  • Experienced the crash twice more tonight without the “drawmodeldecals” command being 0 at startup. If more crash logs are needed, let me know.

    **Note: both crashes occurred when an abundance of poison zombies were in play.


  • Administrators

    I don’t think any more are needed. I’ll disable decals all together until the next update.


Log in to reply
 

6
Online

10974
Users

15257
Topics

297320
Posts

Looks like your connection to NoXiousNet was lost, please wait while we try to reconnect.