A fix for the "toolswhite" console spam error


  • Game Admins

    Every now and then a player might have an error relating to the material “tools\toolswhite”. The error shows up in console as:

    CMaterial::DrawElements: No bound shader
    CMaterial::PrecacheVars: error loading vmt file for tools/toolswhite

    This error is spammed as such high speeds that it lowers a player’s FPS down below ten or even lower. The error however is only spammed when the material is trying to be used within the player’s view, what is actually causing the error is unknown to me.

    A fix I found out was to make a 64x64 image entirely white, name the DXT1 vtf “toolswhite” and place it in “materials/tools”. I also made a vmt file with the shader being “LightmappedGeneric” and placed it in the same place as the vtf.

    I made this fix while the error in question was happening to me in ZS. I looked at a spot where the error was being spammed, placed the vtf/vmt, and then alt-tabbed back into the game. I did not get any more console spam once I re-entered Garry’s Mod.

    I could have just extracted the actual toolswhite material from some game, but it was easier for me to make it instead. Just extract the folder in the rar link into your garrysmod folder.

    http://www.mediafire.com/download/wnabfj8g9hrj561/toolswhitefix.rar


  • Game Admins

    Every now and then a player might have an error relating to the material “tools\toolswhite”. The error shows up in console as:

    CMaterial::DrawElements: No bound shader
    CMaterial::PrecacheVars: error loading vmt file for tools/toolswhite

    This error is spammed as such high speeds that it lowers a player’s FPS down below ten or even lower. The error however is only spammed when the material is trying to be used within the player’s view, what is actually causing the error is unknown to me.

    A fix I found out was to make a 64x64 image entirely white, name the DXT1 vtf “toolswhite” and place it in “materials/tools”. I also made a vmt file with the shader being “LightmappedGeneric” and placed it in the same place as the vtf.

    I made this fix while the error in question was happening to me in ZS. I looked at a spot where the error was being spammed, placed the vtf/vmt, and then alt-tabbed back into the game. I did not get any more console spam once I re-entered Garry’s Mod.

    I could have just extracted the actual toolswhite material from some game, but it was easier for me to make it instead. Just extract the folder in the rar link into your garrysmod folder.

    http://www.mediafire.com/download/wnabfj8g9hrj561/toolswhitefix.rar


  • Administrators

    I think it’s the angelic halo. I searched all the lua files for toolswhite and the halo was using it as its material. I changed it to something else.


Log in to reply
 

5
Online

10903
Users

15224
Topics

296921
Posts

Looks like your connection to NoXiousNet was lost, please wait while we try to reconnect.